Ask the Expert

Boot process freeze with XP/SimplyMepis dual boot

I'm attempting to set up a dual-boot PC. I have installed WinXP Pro on an AMD Athlon XP 1800+ and then installed SimplyMEPIS on the same PC. I used GRUB to set up the dual boot. When I reboot, I can boot MEPIS just fine. But when I try XP, I get these messages and the boot process freezes:

Booting 'Windows at hda1'
rootnoverify (hd0,0)
chainloader +1
savedefault

So I played around with /boot/grub/menu.lst to no avail. This is my partition info:

Number Partition Type Status Usage

01 /dev/hda1 ntfs Active Windows XP
02 /dev/hda2 ext3 Linux mount
03 /dev/hda3 linux-swap Linux Swap
04 /dev/hda4 ext3 Linux Home

What am I missing?

    Requires Free Membership to View

As it happens, I ran into exactly this same problem when doing a dual-boot install. As I remember (this was all about a year ago, so my memory might be a bit hazy), I ended up having to modify the drive characteristics in bios to enable LBA. If you do some poking around the Internet via a search engine, you'll come across a number of postings on this topic.

In the end, I was concerned that, since I would inevitably need to reinstall Windows, I would run into drive formatting issues. I ended up buying a used box to install Linux on. Another strategy would be to install a second drive and put Linux there.

Never fear -- this problem can be solved and you're not that far away from the solution!

This was first published in August 2005

There are Comments. Add yours.

 
TIP: Want to include a code block in your comment? Use <pre> or <code> tags around the desired text. Ex: <code>insert code</code>

REGISTER or login:

Forgot Password?
By submitting you agree to receive email from TechTarget and its partners. If you reside outside of the United States, you consent to having your personal data transferred to and processed in the United States. Privacy
Sort by: OldestNewest

Forgot Password?

No problem! Submit your e-mail address below. We'll send you an email containing your password.

Your password has been sent to: